Cisco to Netapp configuration | How to configure a stacked switch and Netapp Controller

In this blog post I will write about the configuration between a Cisco Catalyst Switch and a NetAPP storage device.
You will see in this example that I’ve used a VLAN tag 10 on the Interfaces which are used for the EtherChannel configuration
Configure first the interface ports which you going to use for the Port-Channel
—————————————————————————————————————————————————-
Go to the configuration mode of the switch [ LACP Configuration ]
default interface g1/0/23
default interface g2/0/23
int range g 1/0/23 , g 2/0/23
 channel-group 1 mode active
Keep the ports in shutdown mode. Go to the Port-Channel 1 interface and configure the interface like below.
int po1
 description virtual interface for etherchannel to filer 1
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 flowcontrol receive on
 spanning-tree portfast
 spanning-tree guard loop
When you configured the interface you have to enable the interfaces.
You can do this with the following commands:
int range g 1/0/23 , g 2/0/23
 no shut
int po 1
 no shut
Below the Final Result of the Cisco Catalyst configuration.
Interface Port-channel1
 description virtual interface for etherchannel to filer 1
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 flowcontrol receive on
 spanning-tree portfast
 spanning-tree guard loop
interface GigabitEthernet1/0/23
 description NETAPP-Contr-1
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 flowcontrol receive on
 channel-group 1 mode active
interface GigabitEthernet2/0/23
description NETAPP-Contr-1
switchport access vlan 10
switchport mode access
switchport nonegotiate
flowcontrol receive on
channel-group 1 mode active
—————————————————————————————————————————————————-
Go to the configuration mode of the switch [ Static configuration ]
default interface g1/0/23
default interface g2/0/23
int range g 1/0/23 , g 2/0/23
 channel-group 1 mode on
Keep the ports in shutdown mode. Go to the Port-Channel 1 interface and configure the interface like below.
int po1
 description virtual interface for etherchannel to filer 1
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 flowcontrol receive on
 spanning-tree portfast
 spanning-tree guard loop
When you configured the interface you have to enable the interfaces.
You can do this with the following commands:
int range g 1/0/23 , g 2/0/23
 no shut
int po 1
 no shut
Below the Final Result of the Cisco Catalyst configuration.
Interface Port-channel1
 description virtual interface for etherchannel to filer 1
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 flowcontrol receive on
 spanning-tree portfast
 spanning-tree guard loop
interface GigabitEthernet1/0/23
 description NETAPP-Contr-1
 switchport access vlan 10
 switchport mode access
 switchport nonegotiate
 flowcontrol receive on
 channel-group 1 mode on
interface GigabitEthernet2/0/23
description NETAPP-Contr-1
switchport access vlan 10
switchport mode access
switchport nonegotiate
flowcontrol receive on
channel-group 1 mode on
—————————————————————————————————————————————————-
Configuration NETAPP Device [ LACP and Static ]
To finish LACP configuration on your Netapp device. You will need to configure LACP on the “vif” of the NETAPP device. If you don’t use LACP you need to configure “multi
LACP Configuration
/etc/rc
#Regenerated by registry Tue May 11 11:57:34 GMT+02:00 2010
#Auto-generated by setup Mon Mar 8 20:26:15 GMT 2010
hostname
vif create lacp vnic1 -b ip e0a e1a
vif create lacp vnic2 -b ip e0b e1b
ifconfig vnic1 `hostname`-vnic1 mediatype auto netmask
ifconfig vnic2 `hostname`-vnic2 netmask  mtusize 9000 trusted wins up
route add default  1
routed on
options dns.domainname
options dns.enable on
options nis.enable off
savecore
Additional notice. ( you see a vif create lacp vnic2 -b- ip e0b e1b, this is an other connection to an other switch not configured by my self )
Static Configuration
/etc/rc
#Regenerated by registry Tue May 11 11:57:34 GMT+02:00 2010
#Auto-generated by setup Mon Mar 8 20:26:15 GMT 2010
hostname
vif create multi vnic1 -b ip e0a e1a
vif create multi vnic2 -b ip e0b e1b
ifconfig vnic1 `hostname`-vnic1 mediatype auto netmask
ifconfig vnic2 `hostname`-vnic2 netmask  mtusize 9000 trusted wins up
route add default  1
routed on
options dns.domainname
options dns.enable on
options nis.enable off
savecore
Additional notice. ( you see a vif create multi vnic2 -b- ip e0b e1b, this is an other connection to an other switch not configured by myself )

6 thoughts on “Cisco to Netapp configuration | How to configure a stacked switch and Netapp Controller”

    1. No, netapp device has 4 network interfaces and 2 controllers. Each controller has 2 network interfaces.
      The one with 9000 MTU is connect with 2 nics to an other switch. Where I couldn’t login too it’s the ISCSI interfaces.
      If you look good to the netapp configuration you see e0a and e1a these 2 are network interfaces on the netapp which I connected to the Cisco catalyst switch.
      I will post in a later stadium the config with static configuration between the Cisco catalyst and the netapp.

      1. If you specify MTU 9000 in RC file you do specify it like the other person said.
        Its actually best practice to let the switch end set it and not hardcode it on the controller. Why? there is a big chance that there will be a device on the network path with 1500 (OK, less today in the past) that could lead to defragmented packages. I have also seen instances where no IP traffic worked unless you set it to 1500.. So there is no good answer to this in real life terms. Anyways, the RC file is out of the questions as of cDOT, 8.3.x and onwards.

        1. Thank for your explanation I’m not really familiar with Netapp and this was a onetime moment with a customer i.c.m. the Cisco Switches.

  1. Hello , I have a doubt.
    If we have to configure a partner interface for filer 1 in Filer 2 ( Dual controller with HA active/active), the filer 2 network interfaces (e0a and e1a) should be in the same port channel group as filer 1 on network switch stack side?
    Regards
    Swaroop

    1. That’s a good one. I don’t know I’m not into Netapp but this configuration was made with someone who did. I can’t help you maybe someone else who is reading this post can help you out.

Leave a Reply to FredCancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.