Cisco Catalyst etherchannel to Synology Diskstation.

To connect a Synology with 2 network nics to a Cisco Catalyst Switch you have to do the following.
Login to the webpage of the synology.
Go to control panel > network. Select network interface
Click on Create > select Link Aggregation Mode > IEEE 802.3ad > OK

Select the LAN interfaces you want to have in the bond 1.
Now you have to configure the Cisco Catalyst the following way:
interface GigabitEthernet1/0/16
description Link-to-synology
switchport mode access
switchport nonegotiate
spanning-tree portfast
channel-group 1 mode active
!
interface GigabitEthernet2/0/15
description Link-to-synology
switchport mode access
switchport nonegotiate
spanning-tree portfast
channel-group 1 mode active
interface Port-channel1
switchport mode access
switchport nonegotiate

1 thought on “Cisco Catalyst etherchannel to Synology Diskstation.”

  1. Thank you. This is exactly what was needed. I did find that I had to run ‘switchport’ first on the Port-channel1 to avoid the ‘rejected: Po1 not a switching port.’ error.

Leave a Reply to bob Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: