How to get another IP range on a KPN Fiber-connection internet.

Today I was lucky to work and had to add and additional IP range to an Fiber connection of a dutch ISP ( KPN )
And the company where I was working got an extra ip range on their fiber connection. the IPS redirect that ip range to your own router connect. which i configure most of the time as bridge first before we add an other device behind it.
start with the DHCP configuration

ip dhcp use vrf connected
!
ip dhcp pool IAS
import all
origin ipcp
dns-server < dns server 1 > <dns server 2>
!
!
no ip domain lookup
ip name-server <dns server 1>
ip name-server <dns server 2>

Then the connection of the internet

interface FastEthernet0/0
 description Link to EVPN CPE
 no ip address
 load-interval 30
 speed 100
 full-duplex
 pppoe enable group global
 pppoe-client dial-pool-number 10

Vlan configuration

interface Vlan1
 ip address pool IAS
 ip access-group 99 out
 ip verify unicast reverse-path
 ip tcp adjust-mss 1452
 load-interval 30

Configure a Dialer interface

interface Dialer10
 description Customer Traffic PPPoE Connection
 mtu 1492
 ip address negotiated
 ip verify unicast reverse-path
 encapsulation ppp
 dialer pool 10
 dialer-group 10
 no cdp enable
 ppp pap sent-username <username> password <username>
 ppp ipcp mask request
 ppp ipcp address accept

You will need to add a router for general use the 0.0.0.0 and the extra ip range.

ip route 0.0.0.0 0.0.0.0 Dialer10
 ip route <extra ip range> <extra ip range subnet> Vlan1

When you have add this extra ip range you can use the new range to an old or new device. the gateway for that device will be the old IP range
Download here a sample configuration

3 thoughts on “How to get another IP range on a KPN Fiber-connection internet.”

  1. hello!This was a really excellent Topics!
    I come from milan, I was luck to seek your subject in bing
    Also I obtain much in your topic really thanks very much i will come daily

    1. Depends on the speed you are using. We have used following devices.
      – Cisco 88x serie
      – Cisco 89x serie
      – Cisco 19xx serie
      – Cisco 29xx serie
      – Cisco 39xx serie

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.