Since a couple of days we get from serveral Dutch ISP a new type of internet connection called VDSL. Below you’ll find a configuration which i used for a dutch ISP to configure the VDSL Line.
* If you have a QWEST internet line with VDSL2 there is a changed configuration to download below this post.
How to start:
go to the configuration Mode of your Cisco IOS Router with VDSL Wic. Like the Cisco Router 887V
controller VDSL 0
!
interface Ethernet0
no ip address
You will need to create a VLAN configuration.. Dot1Q
interface Ethernet0.6
encapsulation dot1Q 6
pppoe enabled group global
pppoe-client dial-pool-number 10
VLAN 1 Configuration ( the local switch )
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
Dialer interface you will need to use to connect witht he PPPOE connection
interface Dialer10
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 10
dialer-group 10
no cdp enable
ppp authentication pap callin
ppp pap sent-username <USERNAME> password <PASSWORD>
!
ip route 0.0.0.0 0.0.0.0 Dialer10 permanent ip nat inside source list 101 interface Dialer10 overload
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any dialer-list 10 protocol ip permit
A full configured router configurion will be posted soon.
Download the Example Configuration. [ click here ]
Because of the tip of Ken here a changed configuration if you are using QWEST [ click here ]
This is very helpful, thank you! I was able to get my Cisco 887V up and running with Qwest because of this. Cisco’s site wasn’t very helpful (they talk about PPPoE over ATM, and PPPoE over ethernet, but not over VDSL2 with a specific VLAN number), and Qwest of course doesn’t support the 887V. The thing to change in the case of Qwest is that the VLAN is 201 instead of 6. Having updated VDSL2 controller firmware is also key, as the upstream speed was 380Kbps instead of 896Kbps. Thanks!
No thank you.
The configuration is created on a dutch ISP. And indeed Cisco website isn’t really helpful to get good information about vdsl2 internet lines.
I haven’s updated the vdsl2 controller firmware at the customers where i installed this kind of router because the max speed on the line is up to 80 mbit/s but they are using 40 mbit/s download and 4 m bit/s up.
Glad that the configuration. helped you to configure it for a Qwest. And also good to know what to change if i ever need to configure a qwest internet vdsl2.
Thanks for the config. I’ve ordered a 887W to connect to a Tele2 Fiberspeed VDSL2 line. As there is no username or password I assume they don’t use PPP. I’ll see how they configured their CPE and proceed from there. This is a good start however.
Got my setup running. The difference with your config example is the VLAN ID (32 instead of 6) and they use CHAP authentication instead of PAP. I also had to use a fake dialer string to get my Dialer interface working. More details on my own blog http://edgetechnology.wordpress.com
Nice you got it running. On a Tele2 Fiberspeed VDSL2 line. just a small adjustment to the VLAN interface and ppp chap / pap. I will keep your log in mind.
Trblshooting No Synch on VDSL, i know this is more of a Config site but i figured someone most of had a issue with VDSL2 n synch if so do i need to do any changes to the base out of the box VVDSL for it to synch wiht my ISP?
@ XVII: You may need to make some changes in your configuration. This depends on your ISP. IN the Netherlands we had to make some changes therefore i placed a example configuration.
glazenbakje: What kind of configuration changes did u have to do..Modem configuration?
You have to look at the VLAN configuration. that’s the first thing you’ve to look at. Someone else wrote me about QWEST ( and US ISP ) and it’s vlan number.
This vlan configuration i should be on the Ethernet port and not on the normal LAN switch ports of the Router..
As well you’ve to look if your ISP is using a PPP dialer connection on the VDSL Line. It may be possible the don’t use this. And than i won’t know how to configure this. Due i haven’t seen it yet.
Pingback: Cisco router configuration for a Tele2 VDSL connection « Edge Technology
I also get the upstream speed maxed out much too low with the default VDSL controller firmware. The reported Attainable Rates are 12580/335 where the upstream speed should be 896.
My firmware version is reported as AvC011b.d21j1 while the current versions available from Cisco are A2pv6C016a1.d22e.150, A2pv6C030.d22e.150, and A2pv6bC014b.d22c.150. I can’t find any documentation that indicates what the different versions are for.
What firmware versions work best with QWest?
Hello Bill,
I don’t know abou QWest the configuration I got was from some one who posted some settings on this blog post.
But you could try a new firmware and look which functions the best for QWest.
Fred
HI;
i Had the same problem with my router 887 VA here in Morocco finaly,i had all of the interface UP and the traffic is there but dialer 0 didn’t have a public IP ) no pppe traffic .
The solution: i upgrad the IOS to the latest version from c880data-universalk9-mz.151-2.T1.bin
to (c880data-universalk9-mz.151-4.M1.bin) then the VSL framwork was upgrad too.
I have the Internet connection with ATM not VLAN .and it’s works fine.
Hello all,
I have a Cisco 887v aswell. I would like to set it up as an bridge.
The following situation would be preferred;
( DUTCH ) ISP -> 887V -> Juniper Firewall ( WAN IP ) -> Switch.
So the only task of the Cisco is to forward all trafic to the Juniper.
I tried it with the following config ( didn’t work )
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname router
boot-start-marker
boot-end-marker
no aaa new-model
memory-size iomem 10
no ip source-route
no ip routing
no ip cef
no ipv6 cef
multilink bundle-name authenticated
license udi pid CISCO887V-SEC-K9 sn FCZ1545C4PB
controller VDSL 0
interface Ethernet0
no ip address
no ip route-cache
!
!
interface Ethernet0.6
encapsulation dot1Q 6 native
no ip route-cache
!
interface BRI0
no ip address
encapsulation hdlc
no ip route-cache
shutdown
isdn termination multidrop
!
!
interface FastEthernet0
!
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface Vlan1
no ip address
no ip route-cache
bridge-group 1
!
!
interface Dialer10
mtu 1492
ip address negotiated
encapsulation ppp
no ip route-cache
dialer pool 10
ppp authentication pap callin
ppp pap sent-username user password 0 pass
no cdp enable
bridge-group 1
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
control-plane
!
!
bridge 1 protocol ieee
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
What should i change to test if it works?
Henri,
What you have to change is the following part of the configuration. ( I hope you got more than 1 IPaddress from your ISP? If you got more than 1 IP address than you could change your configuration to the following setup)
Old part of your configuration
New part of the configuration. You have to change it to.
Give it a try and let me know if this helps. You with your set-up, the Cisco router will be your gateway for your juniper device.
Nope, i have only 1 ip. Its a /32 vdsl line
Hmm that’s to bad, I think this might help a bit:
http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml
I will look if I can find something similar.
I found something which seems to fit in the configuration.
no ip routing
no ip cef
ip subnet-zero
!
interface vlan 1
no ip address
no ip route-cache
bridge-group 1
!
Change this in the Ethernet port
interface Ethernet0.6
encapsulation dot1Q 6 native
no shut
no ip address
no route-cache
bridge-group 1
!
bridge 1 protocol ieee
!
After this you need to setup your juniper firewall with the PPPOE connection information. So that device get the external IP address.
Let me know if it helped.
Thanks for your reply!
I’ve send the request to the company that manages the Juniper.
Ill let you know
Just got a reply from the Juniperguy.
Juniper doesn’t support the PPPOE authentication.
We are gonna discuss about another option of solving the problem.
Maybe an other good option to use:
Configure the Cisco Router with the external IP address and you create a PAT forward to the Juniper device ( the only thing what’s different is that the Cisco Router has an internal IP address and the Juniper device on it’s outside interface an IP address in the internal range of the inside side of the Cisco Router.)
Pingback: Cisco IOS Router | Enable configuration for KPN Customer Fiber Internet ( KPN Glasvezel Particulier ) | Glazenbakje's Weblog
My ISP told me that I needed to set the following:
802.1P must be 0
802.1Q must be 835
So I assume my settings will change to:
interface Ethernet0.835
encapsulation dot1Q 835
pppoe enabled group global
pppoe-client dial-pool-number 10
Is there anything I need to do extra to address the 802.1P value?
I should not know the value you have seems correct to me.
Hi, i am trying to work out an issue i have.
I am trying to setup a C927 to connect on the LAN port 1-4 KPN routers.
I already have internet ipv4 and ipv6 working.
But i would like to connect different routers behind the cisco using a radius server for authentication and forward traffic to the wan side that is configured to use the KPN dialer internet configuration. this must be separated with vlan id.
I think i need to create a bridge interface and one aaa radius server and connect to the different vlan’s. the traffic must be separated of course per vlan.
This configuration is a bit tricky to setup. Could you help?